Mailinglist Archive: opensuse-bugs (4650 mails)

< Previous Next >
[Bug 1043653] New: Sensitivity/pressure data untweakable on Microsoft Precision touchpad on Dell XPS 13
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 09 Jun 2017 14:32:28 +0000
  • Message-id: <bug-1043653-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1043653


Bug ID: 1043653
Summary: Sensitivity/pressure data untweakable on Microsoft
Precision touchpad on Dell XPS 13
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: 64bit
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Kernel
Assignee: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
Reporter: piattj@xxxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101
Firefox/52.0
Build Identifier:

Tap-to-click sensitivity and pressure settings not working. Grayed out in KDE
Plasma's GUI, and synaptics (with synclient) FingerHigh and FingerLow changes
have no effect. Ignoring (in xorg.conf.d) the SynPS/2 Synaptics TouchPad has no
effect (a common forum suggestion). Ignoring (in xorg.conf.d) the DLL075B:01
06CB:76AF Touchpad enables the settings on the GUI, but touchpad becomes
non-functional. Blacklisting psmouse or i2c_hid has no effect. Switching
between libinput or synaptics has no effect in regards to these settings.
Synaptics, at least, allows the setting values to be tweaked, but with no
effect on touchpad behavior. Very frustrating, because while the touchpad is
extremely sensitive (for tap-to-click and for cursor movement), the physical
click mechanism demands quite a bit of force. Therefore touchpad control
demands way too much mental attention while working on the machine.

Reproducible: Always

Steps to Reproduce:
1. Try changing pressure or data settings (e.g. FingerHigh, FingerLow) in
synclient - no effect.
2. Open touchpad GUI settings for pressure/sensitivity - grayed out.
3. Run evemu-record while ignoring DLL075B:01 06CB:76AF Touchpad - no
ABS_PRESSURE, ABS_TOOL_WIDTH, or ABS_MT_PRESSURE events listed.
4. Run evemu-record while ignoring DLL075B:01 06CB:76AF Touchpad -
ABS_PRESSURE, ABS_TOOL_WIDTH, and ABS_MT_PRESSURE events listed, but touchpad
non-functional.


Expected Results:
Pressure settings should be tweakable. With cheap, older laptops like my
Toshiba Netbook and my Asus, it's a breeze, even though they aren't considered
first-rate linux machines, as the XPS is (hmm...).

This probably isn't an Opensuse-specific problem. I ran Mint off a USB, and
results were similar. I also tried LXDE and Mate DE's in Tumbleweed, same
results as in KDE Plasma.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >