Mailinglist Archive: opensuse-bugs (4297 mails)

< Previous Next >
[Bug 1041092] New: elinks fails to install after latest perl update
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 27 May 2017 06:31:48 +0000
  • Message-id: <bug-1041092-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1041092


Bug ID: 1041092
Summary: elinks fails to install after latest perl update
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: x86-64
OS: SUSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: kyrimis@xxxxxxxxxxxxxxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

To install the latest Tumbleweed update, I had to uninstall elinks, because of
conflicts that were encountered. When trying to reinstall it after the upgrade,
zypper produces the error:

Problem: nothing provides perl(:MODULE_COMPAT_5.24.0) needed by
elinks-0.11.996-2.3.x86_64

If I choose to break elinks and install it anyway, it fails to start with the
following error:

elinks: error while loading shared libraries: libperl.so: cannot open shared
object file: No such file or directory

and ldd /usr/bin/elinks | grep "not found" prints:

libperl.so => not found

Sure enough, there is no libperl.so in /usr/lib64.

For vim, which also uses libperl, ldd prints:

libperl.so =>
/usr/lib/perl5/5.24.1/x86_64-linux-thread-multi/CORE/libperl.so
(0x00007f83edc88000)

This suggests that the problem may be as simple as rebuilding elinks, so that
it uses the updated libperl.so.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >