Mailinglist Archive: opensuse-bugs (4295 mails)

< Previous Next >
[Bug 1040198] New: package lomoco: installation error
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 22 May 2017 15:59:50 +0000
  • Message-id: <bug-1040198-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1040198


Bug ID: 1040198
Summary: package lomoco: installation error
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.3
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: comes@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

After I perform a standard installation that includes also the pattern:
KVM Host Server
I found this error in /var/log/zypp/history:

# 2017-05-19 12:31:09 lomoco-1.0-130.1.x86_64.rpm installed ok
# Additional rpm output:
# Updating /etc/sysconfig/logitech_mouse...
# /var/tmp/rpm-tmp.oEOuj8: line 12: mkdir: command not found
# /var/tmp/rpm-tmp.oEOuj8: line 13: touch: command not found
# fillup: Exception in ../SRC/services.c, line 348 concerning file not
opened
#
2017-05-19
12:31:09|install|lomoco|1.0-130.1|x86_64||openSUSE-Leap-42.3-0|06c59d06866f6549fde1d8f9382d621b86366a96|

The problem is that lomoco is installed before coreutils and at that time the
binaries mkdir and touch used in the postinstall scriptlet, are not available
yet.

A possible fix is to add this line in lomoco.spec:

Requires(post): coreutils

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
Follow Ups