Mailinglist Archive: opensuse-bugs (4284 mails)

< Previous Next >
[Bug 1040034] New: multimedia:apps/mpv: should depend on pkgconfig(lua-5.1) or luajit
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 20 May 2017 14:38:16 +0000
  • Message-id: <bug-1040034-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1040034


Bug ID: 1040034
Summary: multimedia:apps/mpv: should depend on
pkgconfig(lua-5.1) or luajit
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: 3rd party software
Assignee: tchvatal@xxxxxxxx
Reporter: 9@cirno.systems
QA Contact: opensuse-communityscreening@xxxxxxxxxxxxxxxxxxxxxx
Found By: ---
Blocker: ---

On Tumbleweed, pkgconfig(lua) pulls in Lua 5.3, which has some breaking changes
that make it incompatible with mpv’s scripting. This breaks some core features
like the on-screen controller. In addition, some popular scripts depend on Lua
5.1 or LuaJIT behavior, so the package should explicitly depend on either of
those (preferably luajit).

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages