Mailinglist Archive: opensuse-bugs (4251 mails)

< Previous Next >
[Bug 1038305] New: zypper does not search properly
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 09 May 2017 16:39:32 +0000
  • Message-id: <bug-1038305-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1038305


Bug ID: 1038305
Summary: zypper does not search properly
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: libzypp
Assignee: zypp-maintainers@xxxxxxxxxxxxxxxxxxxxxx
Reporter: Sauerlandlinux@xxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

If I search with zypper, it only searches up to a dash, after that zypper will
not find any Packages.

zypper se -si python-

will give:

i | dbus-1-python | Paket | 1.2.0-7.34 |
x86_64 | openSUSE-Leap-42.2-Oss
i | dbus-1-python3 | Paket | 1.2.0-7.30 |
x86_64 | openSUSE-Leap-42.2-Oss
i | gimp-plugins-python | Paket | 2.9.5.git20170429-16.1 |
x86_64 | Sauerland-Leap
i | libboost_python1_61_0 | Paket | 1.61.0-1.6 |
x86_64 | openSUSE-Leap-42.2-Oss
i | libboost_python3-1_61_0 | Paket | 1.61.0-1.6 |
x86_64 | openSUSE-Leap-42.2-Oss
.
.
.
i | python3-sip | Paket | 4.16.9-5.4 |
x86_64 | openSUSE-Leap-42.2-Oss
i | python3-six | Paket | 1.9.0-2.2 |
noarch | openSUSE-Leap-42.2-Oss
i | python3-smbc | Paket | 1.0.15.4-4.3 |
x86_64 | openSUSE-Leap-42.2-Oss
i | rpm-python | Paket | 4.11.2-10.1 |
x86_64 | openSUSE-Leap-42.2-Oss
i | zypp-plugin-python | Paket | 0.5-5.3 |
x86_64 | openSUSE-Leap-42.2-Oss

That is ok.


But

zypper se -si python3-s

will give:

Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Keine passenden Objekte gefunden.

Nothing, but it should give f.e. the above Packages:
i | python3-sip | Paket | 4.16.9-5.4 |
x86_64 | openSUSE-Leap-42.2-Oss
i | python3-six | Paket | 1.9.0-2.2 |
noarch | openSUSE-Leap-42.2-Oss
i | python3-smbc

With an Asterisk it will work:

zypper se -si python3-s*
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name | Typ | Version | Arch | Repository
--+--------------------+-------+--------------+--------+-----------------------
i | python3-setuptools | Paket | 33.1.1-175.1 | noarch | KDE-Extra
i | python3-simplejson | Paket | 3.8.0-5.18 | x86_64 | openSUSE-Leap-42.2-Oss
i | python3-sip | Paket | 4.16.9-5.4 | x86_64 | openSUSE-Leap-42.2-Oss
i | python3-six | Paket | 1.9.0-2.2 | noarch | openSUSE-Leap-42.2-Oss
i | python3-smbc | Paket | 1.0.15.4-4.3 | x86_64 | openSUSE-Leap-42.2-Oss

That is not the old behavior.......

Stephan

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >