Mailinglist Archive: opensuse-bugs (4251 mails)

< Previous Next >
[Bug 1037911] Installer seemed confused about encrypted partitions
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 09 May 2017 15:50:20 +0000
  • Message-id: <bug-1037911-21960-iZxGmih9l7@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1037911
http://bugzilla.suse.com/show_bug.cgi?id=1037911#c5

--- Comment #5 from Stefan Hundhammer <shundhammer@xxxxxxxx> ---
(In reply to Neil Rickert from comment #0)
Most of that worked. However, I also wanted to use "/dev/sdb8" to be
mounted at "/shared". That's an encrypted partition.

In the display of partitions, "/dev/sdb8" was not shown as encrypted.

I guess that this was the root of the problem: It did not detect it as
encrypted. And from there on, things went downhill.


I set it to be mounted
as "/shared". When I did that, the partitioner showed it as using "ext4",
which it could only know by looking inside the encryption. (The display of
"/dev/sda8" had similar problems, but I did not plan to use that).

When I accepted the partitioning, the summary showed:
setup encrypted dm device on /dev/sda8
(that was shown in red)
setup encrypted dm device on /dev/sdb8
(that was shown in black)

So it tried to recreate the encryption layer on those devices. Of course that
also destroyed the filesystem (with all its contents) on top of that.

When I tested the scenario in comment #4, it explicitly just said "mount xy as
/data" or something like that; it did not try to mess with the underlying
encryption layer.


During the install it informed me that volume mount of "/dev/sdb8" failed
(trying to mount at "/mnt/shared". The message indicated that the partition
was not valid "ext4". So it apparently attempted to mount without handling
the encryption.

Right; that is consistent with what I suspect.


Just a wild guess: There are three prompts for encryption passwords in the
logs; that means you are using three different passwords for those encrypted
devices.

I suspect that it might get confused if there are many of those encrypted
devices, and all (or at least most) of them are activated during installation,
and then you do stuff in the expert partitioner. Somewhere along the way the
information that those devices are encrypted seems to get lost.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >