Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 1030548] [Build 9.7] openQA test fails in yast2_bootloader "error: install device isn't specified"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 03 May 2017 08:14:28 +0000
  • Message-id: <bug-1030548-21960-SsRoIZi9PZ@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1030548
http://bugzilla.suse.com/show_bug.cgi?id=1030548#c6

--- Comment #6 from Michael Chang <mchang@xxxxxxxx> ---
Downloaded this openQA image from 'asset' :

openSUSE-Leap-42.3-JeOS-for-kvm-and-xen.x86_64-1.1.1-Build9.7.qcow2

And trying to import it to debug the problem with (UEFI) ovmf ...

virt-install --name=jeos-leap-42-3 --arch=x86_64 --vcpus=2 --ram=1024
--network bridge=br0 --disk
path=/home/mchang/Downloads/openSUSE-Leap-42.3-JeOS-for-kvm-and-xen.x86_64-1.1.1-Build9.7.qcow2
--graphics vnc,keymap=us --noautoconsole --boot
loader=/usr/share/qemu/ovmf-x86_64-ms-code.bin,loader_ro=yes,loader_type=pflash,nvram_template=/usr/share/qemu/ovmf-x86_64-ms-vars.bin
--import

It failed in UEFI booting, because ESP (EFI System Partition) cannot be found
on the vm disk image at all.

On the other hand, trying to use legacy-bios mode ..

virt-install --name=jeos-leap-42-3 --arch=x86_64 --vcpus=2 --ram=1024
--network bridge=br0 --disk
path=/home/mchang/Downloads/openSUSE-Leap-42.3-JeOS-for-kvm-and-xen.x86_64-1.1.1-Build9.7.qcow2
--graphics vnc,keymap=us --noautoconsole --import

The grub2 loaded and system booted. So this image looks like not for UEFI
booting and openQA was actually booted in legacy bios mode. That explained why
shim-install cannot work and recognized as i386-pc by grub2-install.

And from

https://openqa.opensuse.org/tests/397086/file/autoinst-log.txt

It looks promising the vm ran in legacy bios mode rather than UEFI since
qemu-kvm did not use any OVMF as emulated UEFI firmware ..

04:45:29.0957 6880 starting: /usr/bin/qemu-kvm -serial file:serial0 -soundhw
ac97 -global isa-fdc.driveA= -vga cirrus -m 1024 -cpu qemu64 -netdev
user,id=qanet0 -device virtio-net,netdev=qanet0,mac=52:54:00:12:34:56 -device
virtio-scsi-pci,id=scsi0 -device virtio-blk,drive=hd1 -drive
file=raid/l1,cache=unsafe,if=none,id=hd1,format=qcow2 -boot
once=d,menu=on,splash-time=5000 -device usb-ehci -device usb-tablet -smp 1
-enable-kvm -no-shutdown -vnc :91,share=force-shared -device virtio-serial
-chardev
socket,path=virtio_console,server,nowait,id=virtio_console,logfile=virtio_console.log
-device
virtconsole,chardev=virtio_console,name=org.openqa.console.virtio_console
-qmp unix:qmp_socket,server,nowait -monitor unix:hmp_socket,server,nowait -S
-monitor telnet:127.0.0.1:20012,server,nowait

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >