Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 984778] add option to zypper up to recognize reboot_needed,relogin_needed,zypp_restart_needed flags in update info, like "zypper patch"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 02 May 2017 22:50:11 +0000
  • Message-id: <bug-984778-21960-OCg4G50OJ9@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=984778
http://bugzilla.opensuse.org/show_bug.cgi?id=984778#c13

--- Comment #13 from Tony Mechelynck <antoine.mechelynck@xxxxxxxxx> ---
(In reply to Michael Andres from comment #12)
JFYI: zypper-1.13.24 supports 'zypper patch --with-update' which will
perform a combination of 'patch' and 'up'. This includes suppressing any
package updates, if patches for the updatestack need to be applied first.

JFYI: the current zypper version on Leap 42.2 (even with the Update-Test repo
enabled) is 1.13.21. I hope the update will appear soon, but in the meantime
I'm still explicitly specifying "-t patch -t package" to both "zypper lu" and
"zypper up", and I usually notice dependency conflicts (of the kind you
mentioned below) by the fact that a "needed" patch is silently not applied, or
only partly, and reappears as "needed" the next time I check for updates (cf.
bug 1034010).


@'zypper up including patches': not per default, because patch installation
may raise dependency conflicts, which is not wanted in plain 'zupper up'.

Ah, OK.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >