Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 1037212] New: openSUSE:Factory pulls in obsolete libreadline5 and blocks all tools using readline
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 02 May 2017 13:36:21 +0000
  • Message-id: <bug-1037212-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1037212


Bug ID: 1037212
Summary: openSUSE:Factory pulls in obsolete libreadline5 and
blocks all tools using readline
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: Other
OS: Other
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Basesystem
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: sebastian.parschauer@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

I've already reported to the opensuse-factory mailing list that the
factory-repo-checker complains about libreadline conflicts and blocks my parted
requests this way.

The problem is that openSUSE:Factory pulls in obsolete libreadline5 while all
tools using readline-devel pull in libreadline7 additionally. readline5-devel
conflicts with readline7-doc.

See:
https://build.opensuse.org/request/show/491642
https://lists.opensuse.org/opensuse-factory/2017-05/msg00014.html

osc meta prjconf openSUSE:Factory | less
...
145 Prefer: libreadline5
...

This line has to be removed or changed to libreadline7.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >