Mailinglist Archive: opensuse-bugs (4292 mails)

< Previous Next >
[Bug 1030548] [Build 9.7] openQA test fails in yast2_bootloader "error: install device isn't specified"
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 02 May 2017 13:33:57 +0000
  • Message-id: <bug-1030548-21960-XzdOzbhRXe@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1030548
http://bugzilla.suse.com/show_bug.cgi?id=1030548#c5

--- Comment #5 from Josef Reidinger <jreidinger@xxxxxxxx> ---
mchang - same happen on my system when doing zypper dup in Tumbleweed.

I debug it and found where is problem. shim passes wrong target to
grub2-install

see my console session:

pepa:/home/jreidinger # grub2-install --no-nvram --removable
Installing for i386-pc platform.
grub2-install: error: install device isn't specified.

pepa:/home/jreidinger # grub2-install --no-nvram --removable
--target=x86_64-efi
Installing for x86_64-efi platform.
Installation finished. No error reported.


pepa:/home/jreidinger # shim-install --config-file=/boot/grub2/grub.cfg
--no-nvram --removable
copying /usr/lib64/efi/grub.efi to /boot/efi/EFI/boot/grub.efi
Installing for i386-pc platform.
/usr/sbin/grub2-install: error: install device isn't specified.



so shim-install do not pass target and grub2-install for unknown reason try to
use i386-pc.

shim-install do not recognize --target option, so I cannot help there with
passing it explicitly.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >