Mailinglist Archive: opensuse-bugs (4258 mails)

< Previous Next >
[Bug 953017] hugin won't start on Tumbleweed due do C++ ABI version mismatch
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 31 Jan 2017 01:38:37 +0000
  • Message-id: <bug-953017-21960-sGvuC2hpex@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=953017
http://bugzilla.opensuse.org/show_bug.cgi?id=953017#c6

Kenneth Ingham <ingham@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |ingham@xxxxxxxx

--- Comment #6 from Kenneth Ingham <ingham@xxxxxxxx> ---
I can confirm the bug on my system. Also, Jan Engelhardt's suggested fix makes
no difference.

Linux Socrates.i-pi.com 4.9.6-1-default #1 SMP PREEMPT Thu Jan 26 09:09:16 UTC
2017 (d1207ac) x86_64 x86_64 x86_64 GNU/Linux

$ rpm -qa | egrep -i 'hugin|wxWidgets' | sort
hugin-2016.2.0-1.4.x86_64
python-wxWidgets-3_0-3.0.2.0-2.10.x86_64
python-wxWidgets-3_0-lang-3.0.2.0-2.10.x86_64
wxWidgets-lang-2.8.12-29.1.noarch

$ hugin
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1002,STL
containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,STL
containers,compatible with 2.8).
Aborted (core dumped)

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >