Mailinglist Archive: opensuse-bugs (4258 mails)

< Previous Next >
[Bug 1022438] New: science: Matplotlib depends on Cycler 0.10.0
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sat, 28 Jan 2017 17:06:19 +0000
  • Message-id: <>

Bug ID: 1022438
Summary: science: Matplotlib depends on Cycler 0.10.0
Classification: openSUSE
Version: unspecified
Hardware: x86-64
OS: Linux
Status: NEW
Severity: Normal
Priority: P5 - None
Component: 3rd party software
Assignee: dmitry@xxxxxxxxxxxx
Reporter: Hans.Aschauer@xxxxxx
QA Contact: opensuse-communityscreening@xxxxxxxxxxxxxxxxxxxxxx
Found By: ---
Blocker: ---


Python Matplotlib 2.0 depends on Cycler Version 0.10, and cannot be imported
with cycler 0.9 from the opensuse leap 42.2 repository

*Steps to reproduce:*

Installed packages:
python-2.7.13 from obs://
(currently python-2.7.13-67.1.x86_64, though the exact version of python-2.7
should not matter)

python-matplotlib from obs://
(currently python-matplotlib-2.0.0-2.1.x86_64)

Empty directory ~/.config/matplotlib/

In a shell, type the following commands:
$ python
Python 2.7.13 (default, Jan 03 2017, 17:41:54) [GCC] on linux2
Type "help", "copyright", "credits" or "license" for more information.
import matplotlib
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/lib64/python2.7/site-packages/matplotlib/", line 1182,
in <module>
rcParams = rc_params()
File "/usr/lib64/python2.7/site-packages/matplotlib/", line 1025,
in rc_params
return rc_params_from_file(fname, fail_on_error)
File "/usr/lib64/python2.7/site-packages/matplotlib/", line 1158,
in rc_params_from_file
if key not in _all_deprecated])
File "/usr/lib64/python2.7/site-packages/matplotlib/", line 907,
in __init__
self[k] = v
File "/usr/lib64/python2.7/site-packages/matplotlib/", line 926,
in __setitem__
cval = self.validate[key](val)
File "/usr/lib64/python2.7/site-packages/matplotlib/", line 853, in
cycler_inst.change_key(prop, norm_prop)
AttributeError: 'Cycler' object has no attribute 'change_key'

*Actual Result*

matplotlib cannot be imported

*Expected result*

No error when import'ing matplotlib


$ sudo pip2 install Cycler==0.10.0

After installing Cycler 0.10 manually, matplotlib works as expected.

*Proposed Solution*

Add Cycler Version 0.10 to the scince repository (named python-Cycler), and
update matplotlib's SPEC file to depend on python-Cycler>=0.10.0.

You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
Follow Ups