Mailinglist Archive: opensuse-bugs (4246 mails)

< Previous Next >
[Bug 1021043] New: vim now requires X libs, which should be avoided
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 20 Jan 2017 08:28:21 +0000
  • Message-id: <bug-1021043-21960@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1021043


Bug ID: 1021043
Summary: vim now requires X libs, which should be avoided
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
Assignee: idonmez@xxxxxxxx
Reporter: behlert@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

vim in version 7.4 could still be installed without any X-lib related packages.
current version 8 in Factory has now these requirements:
libICE.so.6()(64bit)
libSM.so.6()(64bit)
libX11.so.6()(64bit)
libXt.so.6()(64bit)

which means you cannot use vim on a minimal installed system.
I'm not sure which change added this, but vim should be installable without
these dependencies.

In the past, only gvim had these requirements, so I assume some change mixed
this up.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >