Mailinglist Archive: opensuse-bugs (4233 mails)

< Previous Next >
[Bug 1020341] systemd: regression, uaccess no longer works
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 18 Jan 2017 12:06:35 +0000
  • Message-id: <bug-1020341-21960-fHsGsYtIDc@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1020341
http://bugzilla.opensuse.org/show_bug.cgi?id=1020341#c2

Uwe Geuder <novell-ugeuder@xxxxxxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |RESOLVED
Resolution|--- |INVALID
Flags|needinfo?(novell-ugeuder@sn |
|eakemail.com) |

--- Comment #2 from Uwe Geuder <novell-ugeuder@xxxxxxxxxxxxxx> ---
My bug report is invalid, there is no regression from 13.2 to 42.1

In 13.2 I used to have the rules as 70-myusb.rules and the uaccess part worked
fine. However, I had never been able to really use the ID_DRIVE_THUMB part, so
that had been commented out.

Lately I noticed the reason for this is that ID_DRIVE_THUMB is only set by
82-udisk.rules. So when moving to 42.2 at the same time I "fixed" my rules to
be be 85-myusb.rules.

But it looks like uaccess cannot work without rules from 71-seat.rules
73-seat-late.rules, so uaccess broke.

When moving back to 70-myusb.rules uaccess works in 42.2 as it did in 13.2, no
regression.

(For reasons I cannot absolutely not understand my 70-myusb.rules (including
the check for ID_DRIVE_THUMB) do grant uaccess on partitions. For the whole
disk they don't work, which is expected because ID_DRIVE_THUMB is tested before
set. But bugzilla is not troubleshooting forum, so this only as a side note.)

Sorry about the noise caused by the invalid report.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References