Mailinglist Archive: opensuse-bugs (4247 mails)

< Previous Next >
[Bug 1019580] New: lua-devel not installable
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 12 Jan 2017 12:32:14 +0000
  • Message-id: <bug-1019580-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1019580


Bug ID: 1019580
Summary: lua-devel not installable
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Development
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: sweet_f_a@xxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

$ zypper in lua-devel

Problem: nothing provides liblua5_2 = 5.2.2 needed by
lua-devel-5.2.2-4.5.x86_64
Solution 1: do not install lua-devel-5.2.2-4.5.x86_64
Solution 2: break lua-devel-5.2.2-4.5.x86_64 by ignoring some of its
dependencies


Only these one from lua51 and lua52 are available
liblua5_1-5.1.5-12.21.x86_64.rpm
liblua5_2-5.2.4-1.2.x86_64.rpm


The missing lib packages was probably overwritten by the one from lua52. It's a
bit confusing
that we have 3 lua packages

lua-5.2.2
lua51-5.1.5
lua52-5.2.4


For now I workaround using lua52-devel.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >