Mailinglist Archive: opensuse-bugs (3349 mails)

< Previous Next >
[Bug 978424] open-vm-tools: drag & drop and cut & paste between Linux guest and Windows host do not work anymore
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 18 May 2016 08:18:42 +0000
  • Message-id: <bug-978424-21960-PhhgRHLWbi@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=978424
http://bugzilla.opensuse.org/show_bug.cgi?id=978424#c4

--- Comment #4 from Mario Pavlov <Soulstealer@xxxxxx> ---
As far as I can tell vmware-vmblock-fuse is never started and that's why:
vmware-user: could not open /proc/fs/vmblock/dev

So I installed this simple systemd unit to start it:

=================================================================================
[Unit]
Description=Open Virtual Machine Tools (vmware-vmblock-fuse)
ConditionVirtualization=vmware

[Service]
Type=simple
RuntimeDirectory=vmblock-fuse
RuntimeDirectoryMode=755
ExecStart=/usr/bin/vmware-vmblock-fuse -d -f -o
subtype=vmware-vmblock,default_permissions,allow_other /run/vmblock-fuse

[Install]
WantedBy=multi-user.target
=================================================================================

Now vmware-vmblock-fuse seems to run fine and vmblock/dev is present and when I
manually start vmware-user-suid-wrapper I get no errors but the clipboard still
doesn't work.
I'm not sure how vmware-user-suid-wrapper is supposed to work. When I start it,
it immediately exits with 0. Is that what it should do?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References