Mailinglist Archive: opensuse-bugs (3334 mails)

< Previous Next >
[Bug 965140] star uses wrong p7zip compressor
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 01 May 2016 20:59:55 +0000
  • Message-id: <bug-965140-21960-9AfigfbLhm@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=965140
http://bugzilla.opensuse.org/show_bug.cgi?id=965140#c4

--- Comment #4 from Kyrill Detinov <lazy.kent@xxxxxxxxxxxx> ---
(In reply to Jörg Schiling from comment #3)
p7zip is a script that wraps around "7z". You need it because 7z is not UNIX
compress compatible.

This looks like a problem with the distro that forgot to install the script
"p7zip".

Can you please explain, what is the script "p7zip"?

We have the package "p7zip":

% rpm -ql p7zip
/usr/bin/7z
/usr/bin/7za
/usr/lib64/p7zip
/usr/lib64/p7zip/7z
/usr/lib64/p7zip/7z.so
/usr/lib64/p7zip/7zCon.sfx
/usr/lib64/p7zip/7za
/usr/lib64/p7zip/Codecs
/usr/lib64/p7zip/Codecs/Rar.so
/usr/share/doc/packages/p7zip
...
/usr/share/man/man1/7z.1.gz
/usr/share/man/man1/7za.1.gz
/usr/share/man/man1/7zr.1.gz

@Kristyna Streitova
BTW, we don't need /usr/share/man/man1/7zr.1.gz if we don't have a 7zr binary.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages