Mailinglist Archive: opensuse-bugs (4504 mails)

< Previous Next >
[Bug 965140] star uses wrong p7zip compressor
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 07 Feb 2016 22:21:59 +0000
  • Message-id: <bug-965140-21960-6c7v5Pc6hG@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=965140
http://bugzilla.opensuse.org/show_bug.cgi?id=965140#c1

Kristyna Streitova <kstreitova@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |CONFIRMED

--- Comment #1 from Kristyna Streitova <kstreitova@xxxxxxxx> ---
Hi, thank you for your report. I tried to apply a patch that substitutes
'p7zip' for '7z' as you proposed and it solved the compression problem.

# star -c -7z -f archive.tar.7z test
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).

-----

However I bumped into a problem when I tried to extract the '.tar.7z' archive:

# star -x -f test.tar.7z
star: WARNING: Archive is '7z' compressed, trying to use the -7z option.
star: Hard EOF on input, first EOF block is missing at -1.
star: 0 blocks + 0 bytes (total of 0 bytes = 0.00k).
star: Compress program returned error[7].
star: Processed all possible files, despite earlier errors.


When '7z' is used explicitly, it works fine:

# 7z x -so test.tar.7z | star -x -f -
star: 579 blocks + 0 bytes (total of 5928960 bytes = 5790.00k).


I will have to take a look at this.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References