Mailinglist Archive: opensuse-bugs (3256 mails)

< Previous Next >
[Bug 939829] New: nagios from server:monitoring breaks apache due to deprecated config files
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 29 Jul 2015 09:51:56 +0000
  • Message-id: <bug-939829-21960@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=939829


Bug ID: 939829
Summary: nagios from server:monitoring breaks apache due to
deprecated config files
Classification: openSUSE
Product: openSUSE Factory
Version: 201505*
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Apache
Assignee: bnc-team-apache@xxxxxxxxxxxxxxxxxxxxxx
Reporter: wagner-thomas@xxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

On a fresh Tumbleweed installation I installed nagios from server:monitoring.
Then I couldn't restart apache. Journalctl shows:

Jul 29 11:01:18 tumbleweed start_apache2[9496]: AH00526: Syntax error on line
14 of /etc/apache2/conf.d/nagios.conf:
Jul 29 11:01:18 tumbleweed start_apache2[9496]: Invalid command 'Order',
perhaps misspelled or defined by a module not included in the server
configuration

The reason: "Order" is from apache 2.2 but with tumbleweed apache 2.4 is
shipped.

According to http://httpd.apache.org/docs/2.4/upgrading.html two solutions for
this probelm exist:
1) using "Require" instead of order for apache 2.4
2) mod_access_compat can be used.

Solution 1) is IMHO the way to go. However it's incompatible with apache 2.2
and server:monitoring builds for lots of distributions. Is any of these still
using apache 2.2?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >