Mailinglist Archive: opensuse-bugs (3912 mails)

< Previous Next >
[Bug 903553] rp-pppoe not available in the default installation
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 01 Feb 2015 14:06:00 +0000
  • Message-id: <bug-903553-21960-hAtBZhV4ky@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=903553

--- Comment #15 from Aeneas Jai├čle <aj@xxxxxxxxxxx> ---
"ppp-manager: don't use kernel pppoe (rh #1034860, rh #1061641)
The kernel PPPoE code disconnects when it receives a PADT frame, but doesn't
notify userland about it. So if the server sends a PPPoE PADT without having
sent the standard PPP LCP Termination request first, then pppd (and thus
NetworkManager) will not know that the connection has been disconnected. This
should eventually be fixed in the kernel, but for now, work around this by
using the userland pppoe client rather than the kernel code."


http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?h=nm-0-9-10&id=7955806a02db64b20079267743056d7d9d45af3b

Looks like NteworkManager 0.9.10 requires rp-pppoe OR needs to be configured
--with-pppoe=/usr/sbin/pppd.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >