Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 875743] New: puppet-server does not install /etc/sysconfig/puppetmaster
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 29 Apr 2014 23:50:37 +0000
  • Message-id: <bug-875743-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=875743

https://bugzilla.novell.com/show_bug.cgi?id=875743#c0


Summary: puppet-server does not install
/etc/sysconfig/puppetmaster
Classification: openSUSE
Product: openSUSE 13.1
Version: Final
Platform: All
OS/Version: openSUSE 13.1
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: vdziewiecki@xxxxxxxx
ReportedBy: lrupp@xxxxxxxx
QAContact: qa-bugs@xxxxxxx
CC: darin@xxxxxxxxxx, boris@xxxxxxxxx
Found By: Development
Blocker: ---


After installation of the package puppet-server-3.2.4-3.1.1.x86_64 on openSUSE
13.1, there is NO /etc/sysconfig/puppetmaster file (but a file
/var/adm/fillup-templates/sysconfig.puppetmasterd ).

In puppet.spec (from openSUSE:13.1:Update) there is:
%post server
%fillup_and_insserv -f

If I read
https://en.opensuse.org/openSUSE:Packaging_Conventions_RPM_Macros#.25fillup_and_insserv
correctly, this might not be the right call to get a valid
/etc/sysconfig/puppetmaster file installed.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups