Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 874510] New: bluetooth ath3k not working, driver wont load
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 21 Apr 2014 20:07:31 +0000
  • Message-id: <bug-874510-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=874510

https://bugzilla.novell.com/show_bug.cgi?id=874510#c0


Summary: bluetooth ath3k not working, driver wont load
Classification: openSUSE
Product: openSUSE 13.1
Version: Final
Platform: 64bit
OS/Version: openSUSE 13.1
Status: NEW
Severity: Major
Priority: P5 - None
Component: Kernel
AssignedTo: kernel-maintainers@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: jm4062@xxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=587148)
--> (http://bugzilla.novell.com/attachment.cgi?id=587148)
journalctrl -xb log file

User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML,
like Gecko) Chrome/34.0.1847.116 Safari/537.36 SUSE/34.0.1847.116

Hello, I am on OpenSUSE Tumbleweed 3.14.1-24,

Here is my rfkill list:

jamie@linux-3c4q:~> /usr/sbin/rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no
2: acer-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no


I had to use Tumbleweed cause my Ethernet didn't work in the stable oS, but on
the stable oS the BT icon was there and was detected BUT didnt see any
bluetooth devices nor could my phone see it, but now it says No bluetooth
devices found, ive tried modprobe ath3k and modprobe btusb, but still no avail,

lsusb gives me:

Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 002: ID 04ca:300b Lite-On Technology Corp.
Bus 002 Device 003: ID 04f3:0261 Elan Microelectronics Corp.
Bus 002 Device 004: ID 04f2:b3f6 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

I believe I have an Atheros 3K card.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:
No Bluetooth Device Found

Expected Results:
Rocking to my Bluetooth Speakers

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups