Mailinglist Archive: opensuse-bugs (2150 mails)

< Previous Next >
[Bug 874083] New: Using Mail Server module fails when updating mailserver domain type in LDAP
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 17 Apr 2014 02:54:10 +0000
  • Message-id: <bug-874083-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=874083

https://bugzilla.novell.com/show_bug.cgi?id=874083#c0


Summary: Using Mail Server module fails when updating
mailserver domain type in LDAP
Classification: openSUSE
Product: openSUSE 13.1
Version: Final
Platform: x86-64
OS/Version: openSUSE 13.1
Status: NEW
Severity: Major
Priority: P5 - None
Component: YaST2
AssignedTo: yast2-maintainers@xxxxxxx
ReportedBy: jfrickson@xxxxxxxxxxxxxxx
QAContact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101
Firefox/25.0

There are several domains listed in the Mailserver Domains section, all show a
type of "none". Trying to set the type on any one or any combination of
domains, after clicking the "ok" button, the message "Cannot write the mail
server domains" comes up.

In y2log, are the following entries:

2014-04-16 21:48:04 <3> server(5831) [agent-ldap]
LdapAgent.cc(debug_exception):505 ldap error while modifying
zoneName=XXXXXXXX.com,ou=DNS,dc=XXXXXXXX,dc=com (21): Invalid syntax
2014-04-16 21:48:04 <3> server(5831) [agent-ldap]
LdapAgent.cc(debug_exception):507 additional info: objectClass: value #1
invalid per syntax
2014-04-16 21:48:04 <3> server(5831) [-e]
SCR_INIT_FAILED[2375:/usr/share/YaST2/modules/YaPI/MailServer.pm] LDAP modify
failed
2014-04-16 21:48:04 <3> server(5831) [-e] Description: 21 : Invalid syntax
2014-04-16 21:48:04 <2> server(5831) [Ruby] modules/MailServer.rb:769 Cannot
write the mail server domains.

Reproducible: Always

Steps to Reproduce:
1. Start Mail Server configuration
2. Go to Mailserver Domains section
3. Change a type to "Main"
4. Click ok
Actual Results:
LDAP entries not modified.

Expected Results:
Mailserver domain should be set to "Main"

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >