Mailinglist Archive: opensuse-bugs (5295 mails)

< Previous Next >
[Bug 851877] New: Wrong suse_version macro in 13.1
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 22 Nov 2013 17:06:15 +0000
  • Message-id: <bug-851877-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=851877

https://bugzilla.novell.com/show_bug.cgi?id=851877#c0


Summary: Wrong suse_version macro in 13.1
Classification: openSUSE
Product: openSUSE 13.1
Version: Final
Platform: x86-64
OS/Version: Linux
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: emendonca@xxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: Field Engineer
Blocker: ---


The macro "suse_version" is defined in /usr/lib/rpm/suse/macros from the
package "rpm". It should evaluate to "1310", but is still evaluating to "1230"
(from openSUSE 12.3).

# rpm --eval '%{suse_version}'
1230


The problem exists in shipping 13.1 distribution. This will cause problems for
anyone developing RPM packages.

===
Name : rpm
Version : 4.11.1
Release : 6.2.1
Architecture: x86_64
Install Date: Qua 20 Nov 2013 16:14:08 BRST
Group : System/Packages
Size : 4663090
License : GPL-2.0+
Signature : RSA/SHA256, Sex 27 Set 2013 15:05:34 BRT, Key ID b88b2fd43dbdc284
Source RPM : rpm-4.11.1-6.2.1.src.rpm
Build Date : Sex 27 Set 2013 15:05:04 BRT
Build Host : build05
Relocations : (not relocatable)
Packager : http://bugs.opensuse.org
Vendor : openSUSE
Summary : The RPM Package Manager
Description :
RPM Package Manager is the main tool for managing the software packages
of the SuSE Linux distribution.

RPM can be used to install and remove software packages. With rpm, it
is easy to update packages. RPM keeps track of all these manipulations
in a central database. This way it is possible to get an overview of
all installed packages. RPM also supports database queries.
Distribution: openSUSE 13.1
====

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >