Mailinglist Archive: opensuse-bugs (5295 mails)

< Previous Next >
[Bug 848655] Fail to install grub2 during installation

https://bugzilla.novell.com/show_bug.cgi?id=848655

https://bugzilla.novell.com/show_bug.cgi?id=848655#c5


--- Comment #5 from Michael Chang <mchang@xxxxxxxx> 2013-11-07 06:27:06 UTC ---
The created grub.cfg [1] by grub2-mkconfig from log was saying the same thing
with Neil. The /boot was a directory in the encrypted LVM volume, not a mount
point to /dev/sda1 partition.

But it's odd as the /boot seems to be mounted correctly as well [2].

Jiri or Steffen, could you please help to take a look? I would say it's more
installer's issue rather than grub2, as Neil's observation is identical to what
grub2 produces and the whole point is:

"If I unmounted "/boot", then the "/boot" directory on the root file system did
contain all of the normal stuff. Not helpful for booting, since that file
system use encryption.

It looks to me as if "/boot" (or "/dev/sda1") was properly formatted during the
install, but was never mounted."

By the way, my colleague has installed successfully by 13.1 RC2 (build0091)
with a separate /boot partition along side with LVM (no encryption) root
partition. Both are ext3 file system and loader was installed to partition
/boot.

I also loop him in here.

[1]
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod cryptodisk
insmod luks
insmod gcry_rijndael
insmod gcry_rijndael
insmod gcry_sha1
insmod gcry_sha256
insmod lvm
insmod ext2
set root='lvm/nwr2lvm-root'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint='lvm/nwr2lvm-root'
eb232b30-595e-4831-bcaf-d08ff363582e
else
search --no-floppy --fs-uuid --set=root
eb232b30-595e-4831-bcaf-d08ff363582e
fi
echo 'Loading Linux 3.11.6-3-desktop ...'
linux /boot/vmlinuz-3.11.6-3-desktop root=/dev/mapper/nwr2lvm-root
resume=/dev/nwr2lvm/swap splash=silent quiet showopts
echo 'Loading initial ramdisk ...'
initrd /boot/initrd-3.11.6-3-desktop

[2]
2013-10-31 20:39:07 <1> linux(20465) [pbl] yast-6712.1
Library::DefineMountPoints.265: mountpoints =
{
'/' => '/dev/nwr2lvm/root',
'/altsys' => '/dev/sda9',
'/altsys/boot' => '/dev/sda6',
'/altsys/home' => '/dev/sda10',
'/boot' => '/dev/sda1',
'/home' => '/dev/nwr2lvm/home',
'/windows/C' => '/dev/sda3',
'/windows/D' => '/dev/sda5'
}

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References