Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 827314] New: version 2.9.0 of libfuse2 is buggy!
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 28 Jun 2013 13:28:20 +0000
  • Message-id: <bug-827314-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=827314

https://bugzilla.novell.com/show_bug.cgi?id=827314#c0


Summary: version 2.9.0 of libfuse2 is buggy!
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: All
OS/Version: openSUSE 12.3
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: E.Kuemmerle@xxxxxxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101
Firefox/22.0

The version of the libfuse2 package in openSUSE-12.3 is 2.9.0.

There is at least one critcal bug in that version: a missing dereferencing of a
char** in a free() call.
It took me many hours to find that bug which causes a silent crash of the sshfs
deamon in rarely occurring situations.
Then I found that there is the new version 2.9.2 of fuse available since
2012-10-16 and that the relevant bug is fixed in that version!

So please upgrade the package in openSUSE-12.3!


Reproducible: Sometimes

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups