Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 825903] New: librest: use system ca database
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 20 Jun 2013 10:01:52 +0000
  • Message-id: <bug-825903-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=825903

https://bugzilla.novell.com/show_bug.cgi?id=825903#c0


Summary: librest: use system ca database
Classification: openSUSE
Product: openSUSE Factory
Version: 13.1 Milestone 2
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: GNOME
AssignedTo: dimstar@xxxxxxxxxxxx
ReportedBy: lnussel@xxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


librest is built do use /etc/ssl/ca-bundle.pem. Please don't do that. It should
rely on the defaults provided by the crypto libraries instead. Libsoup has a
property 'ssl-use-system-ca-file' that can be used instead of hardcoding a
file. OTOH that's libsoup's default so librest actually shouldn't be setting
anything.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups