Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 822888] New: IPv4-mapped IPv6 addresses do not work
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 3 Jun 2013 15:19:52 +0000
  • Message-id: <bug-822888-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=822888

https://bugzilla.novell.com/show_bug.cgi?id=822888#c0


Summary: IPv4-mapped IPv6 addresses do not work
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: openSUSE 12.3
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Network
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: james.knott@xxxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101
Firefox/20.0 SeaMonkey/2.17 Lightning/2.2b1

IPv4-mapped IPv6 addresses is a method of expressing an IPv4 address as an IPv6
address. For example, 172.16.1.10 would become ::ffff:172.16.1.10. As I
recall, this worked in openSUSE when I tried it about 3 years ago, but it does
not now. As an experiment, I also tried it in Window 7, where it does work.
When I try it in openSUSE, Wireshark shows the computer sending the packet to
the router, which returns an unreachable error. With Windows, the address is
converted to IPv4 as expected.

Here is the Wikipedia link on this:
https://en.wikipedia.org/wiki/IPv6#IPv4-mapped_IPv6_addresses

And the RFC:
https://tools.ietf.org/html/rfc4291
2.5.5.2. IPv4-Mapped IPv6 Address

Reproducible: Always

Steps to Reproduce:
1.ping6 an address such as ::ffff:172.16.1.10
2.That address should be converted to 172.16.1.10
3.ping6 gets an echo
Actual Results:
Instead of converting to an IPv4 address, the IPv4 mapped IPv6 address is sent
to the router, which returns an unreachable error.

Expected Results:
Mapped address should have been converted to IPv4 and pinged the destination.

See also IPv6 Essentials 2nd edition by Silvia Hagen (O'Reilly), page 45.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages