Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 822770] Install of grub2-efi failed

https://bugzilla.novell.com/show_bug.cgi?id=822770

https://bugzilla.novell.com/show_bug.cgi?id=822770#c6


--- Comment #6 from Neil Rickert <nrickert@xxxxxxxxxxxxx> 2013-06-02 12:26:13
UTC ---
I take that back.

The shim-install did not work. It silently failed.

If it had worked, there should have been an entry there for
"opensuse_alt-secureboot" and there isn't. The new entry should have been the
first in the boot order, but entry 4 remained first in the boot order.

I reran the shim-install with:
bash -x /usr/sbin/shim-install --config-file=/boot/grub2/grub.cfg
so that you can see what it is doing.

This echoes my earlier experience. Manually adding an NVRAM entry with
"efibootmgr -c" failed when I ran from a rescue-boot of the 13.1M1 install DVD,
but later succeeded from the 12.3 live rescue system. It looks to me as if
"efibootmgr" is broken. I don't know if that is a code bug or a kernel bug. I
have Tumbleweed on my 12.3 install for that box, so I can manually run
"efibootmgr -c" with either 3.7.10-1.11 kernel or 3.9.3-10 kernel if that would
be useful.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References