Mailinglist Archive: opensuse-bugs (2746 mails)

< Previous Next >
[Bug 822770] New: Install of grub2-efi failed
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 2 Jun 2013 01:53:21 +0000
  • Message-id: <bug-822770-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=822770

https://bugzilla.novell.com/show_bug.cgi?id=822770#c0


Summary: Install of grub2-efi failed
Classification: openSUSE
Product: openSUSE Factory
Version: 13.1 Milestone 0
Platform: x86-64
OS/Version: SUSE Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Bootloader
AssignedTo: jsrain@xxxxxxxx
ReportedBy: nrickert@xxxxxxxxxxxxx
QAContact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101
Firefox/21.0

During the initial install, an error window popped up during boot install. It
indicated a failure of "mkinitrd". However, "initrd" appears to have been
correctly built. I believe it to be a grub2-efi install failure.

I managed to get into the system (booting with the grub menu from a 12.3
system). I attempted to reinstall grub2-efi again. There was a similar popup
window indicating a grub2-efi install failure. I tried several times, each
with the same result.

The initial install problem might be related to Bug 812266 comment 6.

At least some of my attempts were after fixing that problem, disabling secure
boot, and making sure that there would be no nvram conflicts.

I'll note that all of the relevant files were installed in
"/boot/efi/EFI/opensuse_alt". The NVRAM entry was not installed (probably the
cause of the error), and "/boot/grub2/grub.cfg" was not built. I ran
"grub2-mkconfig" to correct that latter problem.

Shortly after the failure (before booting into the system), I booted the
install DVD in rescue mode. I attempted to force-add an NVRAM entry with
"efibootmgr -c". There was no error message, but "efibootmgr -v" done
immediately afterward showed that no entry had been added. I'm not sure
whether that is related. I was able to force-add an entry by booting the 12.3
rescue live CD, and using "efibootmgr -c" from there.

Here are a few lines extracted from "y2log":

2013-06-01 17:49:26 <1> nwr8.cs.niu.edu(2407) [pbl] yast-0930.1
Core::UpdateBoot
loader.1603: rename /etc/default/grub.new -> /etc/default/grub
2013-06-01 17:49:26 <1> nwr8.cs.niu.edu(2407) [pbl] yast-0930.1
Core::RunCommand
.1641: run /usr/sbin/shim-install --config-file=/boot/grub2/grub.cfg
/var/log/Y
aST2/y2log_bootloader 2>&1 - ret 256 + output:
2013-06-01 17:49:26 <3> nwr8.cs.niu.edu(2407) [pbl] yast-0930.1
Core::RunCommand.1642: Error: Command '/usr/sbin/shim-install
--config-file=/boot/grub2/grub.cfg >/var/log/YaST2/y2log_bootloader 2>&1'
failed with code 256 and output:
2013-06-01 17:49:26 <1> nwr8.cs.niu.edu(2407) [YCP]
bootloader/routines/lib_iface.ycp:281 return value from updateBootloader: false

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >