Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 809843] Random eth0/eth1 name space with two Ethernet driver modules

https://bugzilla.novell.com/show_bug.cgi?id=809843

https://bugzilla.novell.com/show_bug.cgi?id=809843#c40


Dr. Werner Fink <werner@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDINFO |ASSIGNED
InfoProvider|werner@xxxxxxxx |

--- Comment #40 from Dr. Werner Fink <werner@xxxxxxxx> 2013-03-28 08:30:20 UTC
---
IMHO

... ATTR{address}=="00:25:22:9f:d6:c9" ... KERNEL=="eth*", NAME="eth0
... ATTR{address}=="00:00:1c:d9:11:e7" ... KERNEL=="eth*", NAME="eth1

versus

eth0 Link encap:Ethernet HWaddr 00:00:1C:D9:11:E7
eth1 Link encap:Ethernet HWaddr 00:25:22:9F:D6:C9

is wrong, isn't it. In other words the persistent rule set had not worked.
Changing naming I had tried several times (before installing the update) and
detected that it may work with the next boot but then found the it also can
fail as the order or eth0/eth1 in comparision to r8169/8139too is random. The
only solution seems to be to load the module for eth0 (which was always r8169
with openSUSE 11.4 the onboard network chip) much before the other module.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References