Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 811301] New: open-vm-tools 9.2.0 does not work with openSUSE 12.3
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 25 Mar 2013 08:20:33 +0000
  • Message-id: <bug-811301-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=811301

https://bugzilla.novell.com/show_bug.cgi?id=811301#c0


Summary: open-vm-tools 9.2.0 does not work with openSUSE 12.3
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: All
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: Soulstealer@xxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101
Firefox/19.0

I installed openSUSE 12.3 x86_64 in VMWare Player and found that most of the VM
tools modules don't work.
The distribution comes with open-vm-tools 9.2.0 which apparently is intended to
work with Linux 3.7. However it doesn't:
=====================================================================================================================
2013-03-15T09:32:04.454635+02:00 linux vmtoolsd[34925]: Starting vmtoolsd
FATAL: Module vmblock not found.
2013-03-15T09:32:04.458165+02:00 linux vmtoolsd[34925]: mount: mount point
/proc/fs/vmblock/mountPoint does not exist
2013-03-15T09:32:04.465696+02:00 linux vmtoolsd[34925]: FATAL: Module vmsync
not found.
2013-03-15T09:32:05.052567+02:00 linux vmtoolsd[34925]: ..done
=====================================================================================================================

At the moment the latest VMWare player offers VMWare-tools 9.2.3. I installed
it and everything worked. However this replaced the original packages which is
not what I want. I want to use packages that are provided only by the official
openSUSE repositories.
So the question is when can we expect to have open-vm-tools (newer than 9.2.0
or more importantly working with openSUSE 12.3) officially available?
I can see that open-vm-tools 9.2.2
(http://sourceforge.net/projects/open-vm-tools/files/open-vm-tools/stable-9.2.x/open-vm-tools-9.2.2-893683.tar.gz/download)
has been available for months.

Reproducible: Always

Steps to Reproduce:
1. Install openSUSE 12.3 x86_64 in VMWare Player 5.0.2 build-1031769
2. Try to use any of the functionality offered by open-vm-tools such as
clipboard integration with the host OS or automatic screen re-size
3. Observe that clipboard integration with the host OS and automatic screen
re-size do not work
4. Observe errors when vmtoolsd is being started:
2013-03-15T09:32:04.454635+02:00 linux vmtoolsd[34925]: Starting vmtoolsd
FATAL: Module vmblock not found.
2013-03-15T09:32:04.458165+02:00 linux vmtoolsd[34925]: mount: mount point
/proc/fs/vmblock/mountPoint does not exist
2013-03-15T09:32:04.465696+02:00 linux vmtoolsd[34925]: FATAL: Module vmsync
not found.
2013-03-15T09:32:05.052567+02:00 linux vmtoolsd[34925]: ..done
Actual Results:
None of the open-vm-tools functionality works.

Expected Results:
Full integration with the host OS provided by open-vm-tools.

I used the Xfce desktop.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
Follow Ups