Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 810232] New: KDE does not detect network after suspend when using ifup network setup
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 19 Mar 2013 11:40:34 +0000
  • Message-id: <bug-810232-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=810232

https://bugzilla.novell.com/show_bug.cgi?id=810232#c0


Summary: KDE does not detect network after suspend when using
ifup network setup
Classification: openSUSE
Product: openSUSE 12.3
Version: Final
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: KDE4 Workspace
AssignedTo: kde-maintainers@xxxxxxx
ReportedBy: srid@xxxxxxxxx
QAContact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.14

I'm running openSUSE 12.3 x86_64 with "traditional ifup" network configuration.
The problem is, when I put my machine to suspend to ram or hibernation, next
time it will resume KDE programs will say that network is unavailable. So I can
not check my emails in kmail, kopete does not reconnect automatically and so
on. Network itself works perfectly, all non-kde programs work well.

I tried calling random dbus methods with qdbusviewer to force kde think network
is up, and it looks kded has an empty list of networks after resume from
suspend.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages