Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 809038] EFI problems - cannot boot windows with secure boot

https://bugzilla.novell.com/show_bug.cgi?id=809038

https://bugzilla.novell.com/show_bug.cgi?id=809038#c31


--- Comment #31 from Neil Rickert <nrickert@xxxxxxxxxxxxx> 2013-03-18 18:11:42
UTC ---
Could you show Windows menu entry?

This is from grub.cfg on the install that boots from second disk:
---- cut here ----
menuentry 'Windows Boot Manager (on /dev/sda1)' --class windows --class os
$menuentry_id_option 'osprober-efi-960A-3282' {
insmod part_gpt
insmod fat
set root='hd0,gpt1'
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1
--hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1 960A-3282
else
search --no-floppy --fs-uuid --set=root 960A-3282
fi
chainloader /efi/Microsoft/Boot/bootmgfw.efi
}
---- end cut here ----

For the other install, the menu entry is identical, with the exception of
the penultimate line, which is:

chainloader /EFI/Microsoft/Boot/bootmgfw.efi

I am doubting that the change from "efi" to "EFI" is why the second of those
works, but I can manually edit grub.cfg and test it.

While we are discussing grub.cfg, there's another discrepancy. I now have the
two installed systems, and each has a grub.cfg entry to boot the other. But
those entries do not specify an "initrd" in the command line. When I boot the
alternate opensuse (the one supposedly booting from first disk), but using the
grub menu from the one booting from the second disk, there is no plymouth
splash, and the prompt for encrypted swap and home gets lost in the noise,
though I did manage to boot it.

During the brief time the system was booting the other way (from the grub in
/dev/sda1), I never actually tested booting the alternative linux. But,
without initrd, that would not have worked at all since that install depends on
an encrypted LVM for which initrd is a requirement.

So there's something wrong with the way that the alternative linux is being
picked up for grub.cfg . I'll probably add a manual "configfile" entry as a
workaround for that.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References