Mailinglist Archive: opensuse-bugs (5243 mails)

< Previous Next >
[Bug 807187] New: rpm: macro expansion fails in SLE
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 3 Mar 2013 12:37:47 +0000
  • Message-id: <bug-807187-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=807187

https://bugzilla.novell.com/show_bug.cgi?id=807187#c0


Summary: rpm: macro expansion fails in SLE
Classification: openSUSE
Product: openSUSE.org
Version: unspecified
Platform: All
OS/Version: Linux
Status: NEW
Severity: Major
Priority: P5 - None
Component: BuildService
AssignedTo: mls@xxxxxxxx
ReportedBy: jengelh@xxxxxxx
QAContact: adrian@xxxxxxxx
Found By: Beta-Customer
Blocker: ---


In SLE11 SP2, rpm macro expansion fails unexpectedly. This plagues both SLE as
well as the SLE environment in OBS.

$ rpm --eval '%{service_del_postun x2gocleansessions.service}'

error: Recursion depth(17) greater than max(16)
15< (empty)
14< (empty)
13< (empty)
12< (empty)
11< (empty)
10< (empty)
9< (empty)
8< (empty)
7< (empty)
6< (empty)
5< (empty)
4< (empty)
3< (empty)
2< (empty)
1< for service in
0<
test -n "$FIRST_ARG" || FIRST_ARG=$1
if test "$FIRST_ARG" -ge 1 ; then
test -f /etc/sysconfig/services && . /etc/sysconfig/services
if test "$YAST_IS_RUNNING" != "instsys" -a
"$DISABLE_RESTART_ON_UPDATE" != yes ; then
for service in

test -n "$FIRST_ARG" || FIRST_ARG=$1
if test "$FIRST_ARG" -ge 1 ; then
test -f /etc/sysconfig/services && . /etc/sysconfig/services
if test "$YAST_IS_RUNNING" != "instsys" -a
"$DISABLE_RESTART_ON_UPDATE" != yes ; then
for service in

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >