Mailinglist Archive: opensuse-bugs (4212 mails)

< Previous Next >
[Bug 724917] Can't start gnucash ("Unknown option name: maxdepth")

https://bugzilla.novell.com/show_bug.cgi?id=724917

https://bugzilla.novell.com/show_bug.cgi?id=724917#c74


C. Andrews Lavarre <alavarre@xxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEEDINFO |NEW
InfoProvider|alavarre@xxxxxxxxx |

--- Comment #74 from C. Andrews Lavarre <alavarre@xxxxxxxxx> 2012-01-31
03:08:24 UTC ---
Oh my, a bit thin skinned we are... but it is late, so we are all to be
excused. This is not easy, I know.

I am simply stating facts, as reported to me, to help us all solve the problem.

If it's any consolation, the GnuCash people are just as frustrated as you...

But as to the substance:
======
Thank you for #53. I did read the *entire* post, as I reported in IRC, but I
already tried it without success under openSUSE 12.1. I DID try Petr's package,
but nothing changes, I still get the

Unknown option name: maxdepth

Error.

If I install the older tar.gz packages from the GnuCash site then I get the
also separately reported errors on dependency hell... I *am progressing in
eliminating these, but ideally the current distro should "just work", which it
does not.
======

We are all in this together. Somewhere in all of this is the truth, the facts.
I'm simply stating the ones I know (the GnuCash response) that moving to Guile
2.0 has broken GnuCash.

======

Now: I have ALSO tried regressing to two older version of GnuCash. I have also
installed all the devel packages I can find, so I AM doing my homework. But it
isn't working.

We need some way to regress Guile 2.0 to Guile 1.8, which I do not know.

=====

Again as reported separately, Guile 1.8 is still on my system, but it has been
renamed guile1. I don't know how to reverse that.

=====
=====
So bottom line: no offense intended, just stating facts, and I know that that
kind of objectivity raises hackles, for which I apologize, but it doesn't
change the facts:

1. GnuCash remains broken in openSUSE 12.1, full stop.

2. This is, allegedly (by the GnuCash developers), because openSUSE 12.1 is
using Guile 2.0 instead of Guile 1.8 and not offering any backward
compatibility to Guile 1.8.

3. My numerous attempts at reconstituting older versions of GnuCash, as well as
following the instructions in comment #53 have failed.

4. I report these facts here in the spirit of teamwork, as we all have a common
enemy. But how can you hope to fix something if you will not listen to the
facts as observed?

5. I want to help. Tell me what I must do to help. Other than what I already
have done, or perhaps just do it all over again. But I have already spent
easily twelve hours on this problem, so I need new information.

Kind Regards, Andy

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >