Mailinglist Archive: opensuse-bugs (3547 mails)

< Previous Next >
[Bug 719027] New: any network transfers pause and restart after some time, connection speed goes up and down
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 19 Sep 2011 23:20:56 +0000
  • Message-id: <bug-719027-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=719027

https://bugzilla.novell.com/show_bug.cgi?id=719027#c0


Summary: any network transfers pause and restart after some
time, connection speed goes up and down
Classification: openSUSE
Product: openSUSE 12.1
Version: Milestone 5
Platform: x86-64
OS/Version: SuSE Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Network
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: mpapis@xxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101
Firefox/6.0

upgraded from 11.4 32bit to 12.1 milestone 5 64bit.

I have problems with getting consistent network speed, it looks like it
stops/pauses transfer for some time and restores it in few long seconds, in
rare cases connection was timed out (eg. in zypper install).

I had similar problems with dns (UDP?) in 11.4 and was using dnsmasq to
overcome it.

Reproducible: Always

Steps to Reproduce:
1. go to speedtest.net, start test
2. go to speedtest.pl, start test
3. go to test.mm.pl(my provider), start test
4. pingtest.net, start test
5. for (( i=1 ; i<=100 ; i++ )) ; do echo test:$i; /usr/bin/time nslookup
niczsoft.com 8.8.8.8 >/dev/null ; done
Actual Results:
it is hard to use network, pages show problems with loading, network is slow,
installing packages timeouts or takes a lot longer

connection goes up and down (see attachment), sometimes can not connect at all,
even the test page loading is affected - the test pages not always loaded fast
and smooth, sometimes they did not loaded at all or showed errors. Sometimes
the stops/pauses continue after second or two, in most cases it continues
before timeout, but sometimes it timeouts too, and when timeout is not
implemented/handled properly it waits forever (over 5 minutes).

pingtest.net errored on me few times, it only first ping response for packet
lost test ... but when running ping to different servers from command line i
get quite stable responses.

nslookup in most times responds very fast (50ms - process spawning time) but
tests 13,28,29,34,36,37,42,63,71,89,100 took 5, 10 or 15 seconds - 5s has to be
internal timeout in nslookup as running with --timeout=2 had identical result
(5,10,15)

Expected Results:
fast network operation

I have tried to do most of the same tests earlier(11.4 32 bit) and all were
working, the same tests on second computer with windows work as expected.

I have 12Mbps connection, and can not use it even in half (avg in tests was
bellow 4).

During installation(upgrade) process everything worked fine, over 1000 packages
downloaded and installed in less then an hour, the system was booted from
Network installation iso cd put on USB memory stick - the only difference I see
there was no NetworkManager involved.

As mentioned on beginning I had similar problems with DNS(UDP) connections
earlier https://bugzilla.novell.com/show_bug.cgi?id=613833 , right now I'm
still use dnsmasq and I get delays on first time domain name resolution, any
subsequent calls are fast.

Also maybe this bug is related
http://bugzilla.novell.com/show_bug.cgi?id=718736 ?

Not sure if this might be related I always disable IPV6 during installation (I
do not have access to any IPV6 capable network).

My WiFi card is: Intel Wireless WiFi Link 5100
My network is secured with WPA2 Personal

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >