Mailinglist Archive: opensuse-bugs (3543 mails)

< Previous Next >
[Bug 492305] No help for Gnucash either in Gnome's Yelp or in the KDE Help Center

https://bugzilla.novell.com/show_bug.cgi?id=492305

https://bugzilla.novell.com/show_bug.cgi?id=492305#c17


--- Comment #17 from David Casson <david.casson@xxxxxxxxxxxx> 2011-09-16
16:35:44 UTC ---
Thank you for that help Johannes

I can confirm some success with your suggested solution.

On my installation of SuSE 11.4 I had already used YaST to install both yelp
and the gnu-cash docs packages. However I repeated it to make sure they are
both present and then I replaced the symlink you mentioned using the following:

rm gnome-help ; ln -s yelp gnome-help

After doing that I now have the link "gnome-help -> yelp" in my /usr/bin
directory instead of linking to SuSE's default KDE help. The result is gnucash
help works fine for the first time since I installed it. Many many thanks.

I feel that there is still a bug here but my lack of understanding of different
folks responsibilities makes it difficult to decide where to direct any
feedback about it. The bottom line is that I have just tried a clean install of
SuSE 11.4 on a spare machine then installed gnucash followed by yelp and find I
still have to use your solution to make the help work. I have not tried any
other gnome applications but suspect the same might apply. Perhaps the bug
could be marked as "Workaround exists" rather than closing it.


It would be very nice were the developers to find away to enable future
releases to recognise the help system needed by non KDE applications without
users having to resort to this sort of command line fix.





(In reply to comment #15)
(In reply to comment #14)
The re-opening should perhaps be qualified by the phrase "for SuSE 11.4
users
with KDE.


Maybe there is a solution for this bug. See FAQ of gnucash:

----snip----
[Novell|open]SuSE
Q: Trying to open the help menu under SuSE, I get the error: "GnuCash could
not
find the files for the help documentation."

A: For some reason SuSE seems always to have bugs relating to the GC docs.

* You may have to use YaST to install the
o yelp and
o gnucash-docs packages.
* In SuSE 11.4 replacing the symlink

/usr/bin/gnome-help -> susehelp

with

/usr/bin/gnome-help -> /usr/bin/yelp

allows GC Help -> Contents to show as expected.

For older SuSE versions: gnome-help has moved from /opt/ to /usr/.
----snap----

Please verify - and maybe close the bug; but please don't fill in this bug
back
in 12.1

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >