Mailinglist Archive: opensuse-bugs (3543 mails)

< Previous Next >
[Bug 578578] Bright control not working at all with Acer Extensa 5635Z

https://bugzilla.novell.com/show_bug.cgi?id=578578

https://bugzilla.novell.com/show_bug.cgi?id=578578#c12


--- Comment #12 from Joey Lee <jlee@xxxxxxxx> 2011-09-14 10:19:25 UTC ---
(In reply to comment #11)
First, sorry for the long delay.
Yes, the option acpi_osi="Linux" helps in both kernels I am using.
This is 2.6.37.6-0.5-desktop and 2.6.39-32-desktop!

In detail:
- the "echo" command above changed the brightness
- the shortcut keys for brightness change work
- the power management changed the brightness when I disconnected from power


Great!

I am quite sure, that I tried also with ACPI options (don't remember which
one)
when I faced that problem first (around 2009/2010), but at that time nothing
helped.

To your questions:
Brightness control never worked on that laptop. But I directly installed
openSUSE on it. The laptop was shipped without a "real" OS. Linpus Linux was
installed by default, which I deleted immediately after one test startup.

Thank you very much for that information! If this is the suggested workaround,
this would be absolutely ok for me. Everything works as expected until now.
I'll leave this option enabled and report if it causes any side effects.

If you need additional info for more investigations or to improve the ACPI
driver in handling poor firmware, do not hesitate to ask.

Again, thank you for your support.

On some Acer machine, their BIOS ship OS with acpi_osi="Linux", but it's not a
good idea because nobody tested the "Linux path" in BIOS, even Acer's ODM also
didn't do the job. That's why kernel acpi team choice suggest avoid to use
acpi_osi=Linux.

If the osi Linux parameter works fine to you, like you said, we should test the
machine after use this parameter, e.g. suspend to RAM or suspend to Disk.

If everything works fine, then that's good! But, we will not to add this
parameter to kernel for the default.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >