Mailinglist Archive: opensuse-bugs (4068 mails)

< Previous Next >
[Bug 714950] New: openSSH - error: Failed to allocate internet-domain X11 display socket +(solution)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 30 Aug 2011 12:29:04 +0000
  • Message-id: <bug-714950-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=714950

https://bugzilla.novell.com/show_bug.cgi?id=714950#c0


Summary: openSSH - error: Failed to allocate internet-domain
X11 display socket +(solution)
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: wharms@xxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Fungus/8.0 (X11; U; C64 6510; de; 8bit)

ssh failed to forward an X11 session suddenly.
"ssh -v user@host" shows no problems (that should be fixed also).

debug1: Enabling compression at level 6.
debug1: Authentication succeeded (keyboard-interactive).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@xxxxxxxxxxx
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LANG = de_DE.UTF-8
Last login: Tue Aug 30 13:57:33 2011 from localhost
Have a lot of fun...


A look into /var/log/messages shows:
error: Failed to allocate internet-domain X11 display socket

I googled and found this hint:
http://forums.opensuse.org/english/get-technical-help-here/network-internet/398918-cant-enable-ssh-x11-forwarding-2.html

i did:
sysctl net.ipv6.conf.all.disable_ipv6=0
and it worked again.

The very odd think is that used to work before and suddenly it stoped working.
So i was unable to see what caused the problem.


Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages