Mailinglist Archive: opensuse-bugs (4068 mails)

< Previous Next >
[Bug 714821] New: PERL include path (@INC) appears to be broken
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 29 Aug 2011 20:45:49 +0000
  • Message-id: <bug-714821-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=714821

https://bugzilla.novell.com/show_bug.cgi?id=714821#c0


Summary: PERL include path (@INC) appears to be broken
Classification: openSUSE
Product: openSUSE 11.4
Version: Factory
Platform: x86-64
OS/Version: openSUSE 11.4
Status: NEW
Severity: Major
Priority: P5 - None
Component: Other
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: jimoe@xxxxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101
Firefox/5.0

opensuse v11.4
linux 2.6.37.6-0.7-desktop x86_64
perl 5.12.3

I updated the server yesterday (Sat Aug 27) and thought that everything went
without a hitch for a change. BZZT!

The server runs an anti-spam proxy, ASSP v1.7.5, that is perl-based. We have
been using the proxy for several years with very little trouble.

After the upgrade whenever a SMTP connection is made, the error "Can't locate
utf8_heavy.pl in @INC" occurs and the connection is dropped. That is, we are
not receiving any mail through the spam filter.

I cannot tell if this is a installation problem or a configuration error in
perl.

Here is the message from ASSP:
2011-08-29 04:31:34 Mainloop: Can't locate utf8_heavy.pl in @INC
(@INC contains:

/usr/lib/perl5/site_perl/5.12.3/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.12.3
/usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.12.3
/usr/lib/perl5/5.12.3/x86_64-linux-thread-multi
/usr/lib/perl5/5.12.3
/usr/local/bin/assp) at /usr/lib/perl5/5.12.3/utf8.pm line 17.;

(Note: I added the line breaks for clarity.)

<utf_heavy.pl> does exist in </usr/lib/perl5/5.12.3/>. All of those paths exist
but the only one with all the goodies is </usr/lib/perl5/5.12.3/> which seems
to be ignored.


Reproducible: Always

Steps to Reproduce:
1. Install and configure ASSP
2. Send an email from a remote SMTP server through the proxy
3. See the connection immediately broken because of the perl error
Actual Results:
Remote SMTP MTAs cannot send mail to our sever through the proxy.


Expected Results:
ASSP through an error about the missing code module and broke the connection.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >