Mailinglist Archive: opensuse-bugs (4068 mails)

< Previous Next >
[Bug 714724] New: rpm does not honor version on Obsoletes
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 29 Aug 2011 14:02:40 +0000
  • Message-id: <bug-714724-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=714724

https://bugzilla.novell.com/show_bug.cgi?id=714724#c0


Summary: rpm does not honor version on Obsoletes
Classification: openSUSE
Product: openSUSE 12.1
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: bwiedemann@xxxxxxxx
QAContact: qa@xxxxxxx
CC: mls@xxxxxxxx
Found By: Development
Blocker: ---


on a fresh factory KDE install I did

susetest:~ # rpm -q akonadi akonadi-runtime
akonadi-4.7.0-4.1.x86_64
akonadi-runtime-1.6.0-4.3.x86_64
susetest:~ # rpm -qV akonadi
Unsatisfied dependencies for akonadi-4.7.0-4.1.x86_64:
akonadi < 4.1 is obsoleted by (installed)
akonadi-runtime-1.6.0-4.3.x86_64

which looks as if rpm does not honor the version on Obsoletes


akonadi-runtime.spec has
# rename from 10.3, which had 4.x version
Provides: akonadi = %{version}
Obsoletes: akonadi < 4.1


the akonadi package is built from kdepim4

https://build.opensuse.org/package/files?package=kdepim4&project=KDE%3ADistro%3AFactory
https://build.opensuse.org/package/files?package=akonadi-runtime&project=KDE%3ADistro%3AFactory

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >