Mailinglist Archive: opensuse-bugs (4068 mails)

< Previous Next >
[Bug 714201] e2fsck made ext4 filesystem unmountable after conversion from ext3

https://bugzilla.novell.com/show_bug.cgi?id=714201

https://bugzilla.novell.com/show_bug.cgi?id=714201#c1


--- Comment #1 from Andreas Nordal <andreas_nordal_4@xxxxxxxxxxx> 2011-08-25
16:19:45 UTC ---
Good news! I desparately tried e2fsck using different superblocks, seeing the
same familiar errors again. I cluelessly answered 'y' to fix some of them. I
didn't let e2fsck finish. Now, the filesystem mounts!

It looks like no data is lost: Files are readable, "df" says 57% use,
lost+found/ is empty.

According to "tune2fs -l", the filesystem is "not clean with errors". It was
writable immediately after I mounted it, but became read-only as expected.

I think I only tried the first 4 backup superblocks. Output of "dumpe2fs
/dev/md0 | grep -i superblock":
Primary superblock at 0, Group descriptors at 1-117
Backup superblock at 32768, Group descriptors at 32769-32885
Backup superblock at 98304, Group descriptors at 98305-98421
Backup superblock at 163840, Group descriptors at 163841-163957
Backup superblock at 229376, Group descriptors at 229377-229493
Backup superblock at 294912, Group descriptors at 294913-295029
Backup superblock at 819200, Group descriptors at 819201-819317
Backup superblock at 884736, Group descriptors at 884737-884853
Backup superblock at 1605632, Group descriptors at 1605633-1605749
Backup superblock at 2654208, Group descriptors at 2654209-2654325
Backup superblock at 4096000, Group descriptors at 4096001-4096117
Backup superblock at 7962624, Group descriptors at 7962625-7962741
Backup superblock at 11239424, Group descriptors at 11239425-11239541
Backup superblock at 20480000, Group descriptors at 20480001-20480117
Backup superblock at 23887872, Group descriptors at 23887873-23887989
Backup superblock at 71663616, Group descriptors at 71663617-71663733
Backup superblock at 78675968, Group descriptors at 78675969-78676085
Backup superblock at 102400000, Group descriptors at 102400001-102400117
Backup superblock at 214990848, Group descriptors at 214990849-214990965

I have one theory: It may seem like the primary superblock is slightly corrupt.
Since this is block 0 of a filesystem starting at the beginning of the storage
medium, this would be the location of MBR, had I chosen to partition my disks.
Could it be that some program is making the wrong assumption about my
nonexisting partition table?

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
References