Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 713408] New: Yast2 apparmor module crash on factory
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 22 Aug 2011 10:52:41 +0000
  • Message-id: <bug-713408-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=713408

https://bugzilla.novell.com/show_bug.cgi?id=713408#c0


Summary: Yast2 apparmor module crash on factory
Classification: openSUSE
Product: openSUSE 12.1
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: YaST2
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: bruno@xxxxxxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---
Blocker: ---


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101
Firefox/6.0 FirePHP/0.4

With an up to date (2011-08-21) factory install
If you try to manage apparmor with Yast2 the module crash.


After opening the settings module you check the checkbox enable (which should
already be checked as aa-status return running)

setup the email or not. then click on set profiles mode
nothing happen in foreground.
There's a ag_complaint process running and eating cpu.

This is not related to new version of apparmor

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:
crash

Expected Results:
able to use it

Yast2 perl error dialog box contain
Can't locate Immunix/SubDomain.pm in @INC (@INC contains:
/usr/lib/perl5/site_perl/5.14.1/x86_64-linux-thread-multi
/usr/lib/perl5/site_perl/5.14.1
full trace in attachement

See gdb attachement too

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >