Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 713325] New: Grub cannot install boot loader
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 21 Aug 2011 00:14:47 +0000
  • Message-id: <bug-713325-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=713325

https://bugzilla.novell.com/show_bug.cgi?id=713325#c0


Summary: Grub cannot install boot loader
Classification: openSUSE
Product: openSUSE 12.1
Version: Milestone 3
Platform: i686
OS/Version: openSUSE 11.4
Status: NEW
Severity: Critical
Priority: P5 - None
Component: Installation
AssignedTo: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: mlemos@xxxxxxx
QAContact: jsrain@xxxxxxxxxx
Found By: ---
Blocker: Yes


I got an HP ProBook 4520s that comes with 500 GB with Windows 7.

It comes with 4 partitions: SYSTEM, the main Windows partition, HP Recovery and
HT Tools.

I tried to have OpenSuse installation to resize the Windows larger partition
but it said that it couldn't with this message:

"The partition on disk /dev/sda is not readable by the partitioning tool
parted, which is used to change the partition table.

You can use the partitions on disk /dev/sda as they are. You can format them
and assign mount points to them, but you cannot add, edit, resize, or remove
partitions from that disk with this tool."

So I resized the Windows partition from Windows 7 and added 3 partitions on the
empty space for Linux: /, swap and /home. Still OpenSuSE installation has shown
this warning message:

"The bootloader is installed on a partition that does not lie entirely below
128 GB. The system might not boot if BIOS support only lba24 (result is error
18 during grub MBR)."

I configured OpenSuSE installation to install on those partitions but Grub
could not install the boot loader with this message:

"grub> setup --stage=/boot/grub/stage2 --force-lba (hd0,2) (hd0,2)

Error 17: Cannot mount selected partition

grub> quit"

I already tried this in OpenSuSE 11.4 but I suspected it needed newer parted
and grub versions, so I also tried OpenSuSE 12.1 milestone 3 with the same
results.

The installation finishes but no Grub boot menu appears, it goes to Windows as
if no Linux was installed, although the installed version is there in the 3
partitions that were created on Windows, I just cannot make them boot.

Is there a solution to workaround these problems?

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >