Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 701076] openSUSE 11.4 doesn't shutdown normally

https://bugzilla.novell.com/show_bug.cgi?id=701076

https://bugzilla.novell.com/show_bug.cgi?id=701076#c1


James PEARSON <pearson44j@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |pearson44j@xxxxxxxxxx

--- Comment #1 from James PEARSON <pearson44j@xxxxxxxxxx> 2011-08-20 11:54:08
CEST ---
Last weekend (Aug 13 2011) I put a new MSI 890FXA-GD70 motherboard (+ updated
it to the latest BIOS) and an AMD Phenom(tm) II X6 1100T Processor in my main
PC

The first thing I did after doing a fresh install of openSUSE 11.4 x86_64 (and
updating the BIOS) was to deactivate Cool&Quiet in the BIOS so that all 6 cores
showed up in /proc/cpuinfo (cpuinfo shows MHz 3300.048)

The "shutdown -h now" (/sbin/shutdown -h now) command no longer worked using an
old script which I run from the crontab

The command "/sbin/shutdown -h now" does not work if I run it from the line
command either - see Ex 1 and 2 below

# OS: openSUSE 11.4 x86_64
# Ex 1
Sending all processes the TERM signal...
/etc/initd.d/rc: line 343: 15115 Killed
$link start reached
Master Resource Control: runlevel 0 has been
Skipped services in runlevel 0:


# Ex 2
Shutting down service (localfs) network . . . . . . . . . .
Running /etc/init.d/halt.local

The system time is in sync with Hardware Clock
Sending all processes the TERM signal...
Sending all processes the KILL signal...
Segmentation fault
Master Resource Control: runlevel 0 has been
Skipped services in runlevel 0:

The command "/sbin/shutdown -h now" does not work if I run it from the line
command from init 3. I tried this because I thought that this issue was related
to kde after googling.

Last week end I also installed a new hard drive in a Lenovo X200s laptop and
did a fresh install of openSUSE 11.4 i586
I added the same zypper repositories and ran the same update scripts
The "shutdown -h now" command works fine on my laptop which has a low power
Intel CPU!

I downloaded and installed the sysvinit and sysvinit-tools rpms (see below)
from factory on my new MSI 890FXA-GD70 motherboard - same problem – the
"shutdown -h now" command still ***did not work***

-rw-r--r-- 1 jpearson users 72067 Aug 17 06:10 sysvinit-2.88+-59.2.x86_64.rpm
-rw-r--r-- 1 jpearson users 178853 Aug 17 06:11
sysvinit-tools-2.88+-59.2.x86_64.rpm

During the week I did a fresh install of openSUSE version i586 on my MSI 890FXA
motherboard thinking the shutdown problem would be solved.
I noticed no change however - the shutdown command does not work on either
v11.4 x86_64 nor v11.4 i586

# Kernel rpm installed on openSUSE version i586
rpm -qa | grep -i kernel
kernel-firmware-2.6.38-1.2.1.noarch
kernel-desktop-devel-2.6.37.6-0.7.1.i586
kernel-devel-2.6.37.6-0.7.1.noarch
kernel-desktop-2.6.37.6-0.7.1.i586
kernel-source-2.6.37.6-0.7.1.noarch


To resume - The "shutdown -h now" (/sbin/shutdown -h now) command no longer
works on versions x86_64 and 586 of openSUSE 11.4 since I installed a
MSI 890FXA-GD70 motherboard (with latest BIOS) and an AMD Phenom(tm) II X6
1100T Processor

Note: Cool'n'Quiet technology is DISABLED in the BIOS - otherwise why buy an X6
CPU?

I will confirm that the workaround «enable Cool'n'Quiet technology" works for
me

Please note that the workaround «enable Cool'n'Quiet technology" is obviously
not an acceptable option (leaving the computer on is).

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
< Previous Next >