Mailinglist Archive: opensuse-bugs (4046 mails)

< Previous Next >
[Bug 712300] New: systemd: service startup order not blocking
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 15 Aug 2011 18:04:41 +0000
  • Message-id: <bug-712300-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=712300

https://bugzilla.novell.com/show_bug.cgi?id=712300#c0


Summary: systemd: service startup order not blocking
Classification: openSUSE
Product: openSUSE 12.1
Version: Factory
Platform: Other
OS/Version: Other
Status: NEW
Severity: Major
Priority: P5 - None
Component: Basesystem
AssignedTo: fcrozat@xxxxxxxxxx
ReportedBy: dimstar@xxxxxxxxxxxx
QAContact: qa@xxxxxxx
Found By: Community User
Blocker: ---


Seems a vast of users is seeing this issue:

There are 'two' scenarios, this bug us about the '2nd one':
1) Boot takes 5 minutes (This is the 'known' NM_ONLINE_TIMEOUT)
2) Once NM_ONLINE_TIMEOUT is set to 0, the boot is 'fast' but it does not come
up grapical.

At least those two services are missing:
NetworkManager.service
xdm.service

The issue for both is that they are started in parallel or before dbus is
running.
(NM is 'tried' to be started from /etc/init.d/network) and xdm is a
'traditional' start script anyway.

As a result, the boot 'ends with a login' prompt.
Logging in and then
systemctl start NetworkManager.service
systemctl start xdm.service
brings up a fully functional Environment for me. (Perfectly suitable for me now
as a workaround).

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >