Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 711708] New: xorg crashes sometimes after resume
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 11 Aug 2011 08:44:22 +0000
  • Message-id: <bug-711708-21960@http.bugzilla.novell.com/>

https://bugzilla.novell.com/show_bug.cgi?id=711708

https://bugzilla.novell.com/show_bug.cgi?id=711708#c0


Summary: xorg crashes sometimes after resume
Classification: openSUSE
Product: openSUSE 11.4
Version: Final
Platform: x86-64
OS/Version: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: X.Org
AssignedTo: bnc-team-xorg-bugs@xxxxxxxxxxxxxxxxxxxxxx
ReportedBy: jslaby@xxxxxxxxxx
QAContact: xorg-maintainer-bugs@xxxxxxxxxxxxxxxxxxxxxx
Found By: ---
Blocker: ---


Created an attachment (id=445327)
--> (http://bugzilla.novell.com/attachment.cgi?id=445327)
xorg.log with crash

Sometimes, when I resume and it switches the console, the server crashes as
below. I'm running 11.4 + tumbleweed:
kernel-desktop-3.0.0-1.1.x86_64
kernel-desktop-3.0.1-1.1.x86_64
kernel-desktop-devel-3.0.0-1.1.x86_64
kernel-desktop-devel-3.0.1-1.1.x86_64
kernel-devel-3.0.0-1.1.noarch
kernel-devel-3.0.1-1.1.noarch
kernel-firmware-20110709-47.1.noarch
nfs-kernel-server-1.2.3-27.1.x86_64
xorg-x11-7.6-43.44.1.x86_64
xorg-x11-driver-input-7.6-29.1.x86_64
xorg-x11-driver-video-7.6-53.58.1.x86_64
xorg-x11-driver-video-intel-legacy-2.9.1-8.1.x86_64
xorg-x11-driver-video-radeonhd-1.3.0_20100512_80ba041-2.1.x86_64
xorg-x11-driver-video-unichrome-20091206-9.1.x86_64
xorg-x11-fonts-7.6-10.1.noarch
xorg-x11-fonts-core-7.6-10.1.noarch
xorg-x11-libfontenc-7.6-6.1.x86_64
xorg-x11-libfontenc-32bit-7.6-6.1.x86_64
xorg-x11-libICE-7.6-8.1.x86_64
xorg-x11-libICE-32bit-7.6-8.1.x86_64
xorg-x11-libs-7.6-16.1.x86_64
xorg-x11-libSM-7.6-7.1.x86_64
xorg-x11-libSM-32bit-7.6-7.1.x86_64
xorg-x11-libs-32bit-7.6-16.1.x86_64
xorg-x11-libXau-7.6_1.0.6-6.1.x86_64
xorg-x11-libXau-32bit-7.6_1.0.6-6.1.x86_64
xorg-x11-libxcb-7.6_1.7-8.1.x86_64
xorg-x11-libxcb-32bit-7.6_1.7-8.1.x86_64
xorg-x11-libXdmcp-7.6-7.1.x86_64
xorg-x11-libXdmcp-32bit-7.6-7.1.x86_64
xorg-x11-libXext-7.6_1.2.0-2.1.x86_64
xorg-x11-libXext-32bit-7.6_1.2.0-2.1.x86_64
xorg-x11-libXfixes-7.6_4.0.5-6.1.x86_64
xorg-x11-libXfixes-32bit-7.6_4.0.5-6.1.x86_64
xorg-x11-libxkbfile-7.6-6.1.x86_64
xorg-x11-libxkbfile-32bit-7.6-6.1.x86_64
xorg-x11-libXmu-7.6-7.1.x86_64
xorg-x11-libXmu-32bit-7.6-7.1.x86_64
xorg-x11-libXp-7.6-2.1.x86_64
xorg-x11-libXpm-7.6-6.1.x86_64
xorg-x11-libXpm-32bit-7.6-6.1.x86_64
xorg-x11-libXprintUtil-7.6-2.1.x86_64
xorg-x11-libXprintUtil-32bit-7.6-2.1.x86_64
xorg-x11-libXp-32bit-7.6-2.1.x86_64
xorg-x11-libXrender-7.6_0.9.6-6.1.x86_64
xorg-x11-libXrender-32bit-7.6_0.9.6-6.1.x86_64
xorg-x11-libXt-7.6_1.0.9-4.1.x86_64
xorg-x11-libXt-32bit-7.6_1.0.9-4.1.x86_64
xorg-x11-libXv-7.6-6.1.x86_64
xorg-x11-libXv-32bit-7.6-6.1.x86_64
xorg-x11-libX11-7.6-10.2.x86_64
xorg-x11-libX11-32bit-7.6-10.2.x86_64
xorg-x11-server-7.6_1.9.3-15.24.2.x86_64
xorg-x11-server-debuginfo-7.6_1.9.3-15.24.2.x86_64
xorg-x11-server-extra-7.6_1.9.3-15.24.2.x86_64
xorg-x11-xauth-7.6-43.44.1.x86_64

xorg-x11-server-debuginfo is new, the trace generated is not with debuginfo, so
it's incomplete... I will attach output of gdb.

My card:
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV515 [Radeon
Mobility X1450] [1002:7186]

(II) AIGLX: Resuming AIGLX clients after VT switch
(II) RADEON(0): EDID vendor "CMO", prod id 5392
(II) RADEON(0): Printing DDC gathered Modelines:
(II) RADEON(0): Modeline "1400x1050"x0.0 108.00 1400 1448 1560 1688 1050
1053 1057 1066 -hsync -vsync (64.0 kHz)
Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x483068]
1: /usr/bin/Xorg (0x400000+0x5e6d9) [0x45e6d9]
2: /lib64/libc.so.6 (0x7f7b2fb4b000+0x32b30) [0x7f7b2fb7db30]
3: /usr/bin/Xorg (0x400000+0x14e48f) [0x54e48f]
4: /usr/bin/Xorg (0x400000+0x14cebc) [0x54cebc]
5: /usr/bin/Xorg (0x400000+0x14d134) [0x54d134]
6: /usr/bin/Xorg (xf86Wakeup+0x44d) [0x46b90d]
7: /usr/bin/Xorg (WakeupHandler+0x4b) [0x446ffb]
8: /usr/bin/Xorg (WaitForSomething+0x1ca) [0x45c02a]
9: /usr/bin/Xorg (0x400000+0x522e2) [0x4522e2]
10: /usr/bin/Xorg (0x400000+0x25ace) [0x425ace]
11: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f7b2fb69bfd]
12: /usr/bin/Xorg (0x400000+0x25679) [0x425679]
Segmentation fault at address (nil)
Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >