Mailinglist Archive: opensuse-bugs (4067 mails)

< Previous Next >
[Bug 704981] IPV6_PRIVACY="yes" but not working...

https://bugzilla.novell.com/show_bug.cgi?id=704981

https://bugzilla.novell.com/show_bug.cgi?id=704981#c2


Marius Tomaschewski <mt@xxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |RESOLVED
CC| |lnussel@xxxxxxxxxx,
| |mvidner@xxxxxxxxxx
Resolution| |WONTFIX

--- Comment #2 from Marius Tomaschewski <mt@xxxxxxxxxx> 2011-08-09 15:13:02 UTC
---
The problem is that the settings are applied too late: the interface
already exists [hardware is already detected and interface name has
been assigned by the kernel] _before_ the default.use_tempaddr setting
gets applied (may happen in both cases, for IPV6_PRIVACY as well as
with /etc/sysctl.conf).

-> default has no effect for already existing interfaces

=> bug 494958 and bug 664550.

In some cases, a per inteface it can't be applied because the kernel
removes the complete /proc/sys/net/ipv6/conf/eth0 directory while e.g.
"ip addr flush dev XXX".

=> bug 559170 / bug 580018.

Resolving as WONTFIX: the deprecated IPV6_PRIVACY can't be fixed
properly.

Workaround is to use ifsysctl files see "man 5 ifsysctl" and set it
for the wlan0 interface (or for $INTERFACE), so it is applied via
udev rule and in ifup.

When NetworkManager is used, IFSYSCTL_NETWORKMANAGER=yes should be
set to enable the ifsysctl run via udev.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >
This Thread
  • No further messages