Mailinglist Archive: opensuse-bugs (4037 mails)

< Previous Next >
[Bug 686489] xkb: mapped key symbols are not correctly sent to applications

https://bugzilla.novell.com/show_bug.cgi?id=686489

https://bugzilla.novell.com/show_bug.cgi?id=686489#c8


Joon Ro <joonpyro@xxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |joonpyro@xxxxxxxxx

--- Comment #8 from Joon Ro <joonpyro@xxxxxxxxx> 2011-08-04 15:57:03 UTC ---
I am actually having similar problem. I'm using colemak layout, and I also
wanted to swap the the grave key with the backspace key. So I added the
following to /usr/share/X11/xkb/symbols/us file:

partial alphanumeric_keys
xkb_symbols "colemak-joon" {
include "us(colemak)"
name[Group1]= "USA - Colemak Joon";

// Alphanumeric section
key <TLDE> { [ BackSpace, BackSpace, BackSpace,
BackSpace ] };
key <BKSP> { [ grave, asciitilde, dead_tilde,
asciitilde ] };

include "level3(ralt_switch)"
};

Now the problem is that I cannot type asciitilde. With this layout, whenever I
press shift+backspace key, I get `, not ~.

I think this is an openSUSE bug because I remember I did not have this problem
with 11.3, and I recently tried this with Chakra linux with exactly the same
/usr/share/X11/xkb/symbols/us file, and I could type asciitilde with
shift+backspace without any problem.

--
Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

< Previous Next >